Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
raspberry pi, starting ehorus using sudo service
#1
Hi,

Raspberry Pi 3 running latest Raspbian

when I use
/etc/init.d/ehorus_agent_daemon start
to manually start the daemon,
it works.
eHorus Agent is running with PID 1550.

when I use

sudo service ehorus_agent_daemon start
to start it as a service
it fails.

/etc/init.d/ehorus_agent_daemon status
shows

eHorus Agent is not running.

Also, I can't use any of the following either...

sudo update-rc.d ehorus_agent_daemon defaults
sudo update-rc.d ehorus_agent_daemon defaults 92

I have tried many different ways to script the auto-run of ehorus, and none work.

Agent version
0.8.1

Thanks,
Xenek

Just an extra note,

sudo update-rc.d ehorus_agent_daemon enable
insserv: warning: current start runlevel(s) (2 3 5) of script `ehorus_agent_daemon' overrides LSB defaults (2 3 4 5).

any clues or things I could try?
 Reply
#2
I managed to get it working using

in rc.local

(sleep 30; /home/pi/starteh.sh) &

in /home/pi/starteh.sh

/etc/init.d/ehorus_agent_daemon start

But it's probably not optimal.

Trying v1.0.0 now...
 Reply
#3
Hi Xenek,

The problem with the service is bug on the version 0.8.1.of raspberry.
Ours developers are working to fix it.
I inform you when the version is ready.
Thanks for the information.

Best regards,

vic.
 Reply
#4
Your discussion helped me too. Thanks. https://luckypatcher.pro/apk/
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | ehorus.com

Theme © MyBB Themes